TunSafe Forum

Welcome to the TunSafe Community Forum. This is open for discussions related to TunSafe and the WireGuard protocol.

You are not logged in.

#1 2019-04-26 12:38:46

BlackEyed
Member
Registered: 2019-04-23
Posts: 1

Tunsafe/Wireguard macOS routing problems

I'm using Tunsafe on macOS 10.14.2, I am able to connect to my remote LAN through Wireguard, but I can't access the internet when connected. I can, however access any computer within the LAN.



Using the same setup, I can access the LAN and internet from the iOS Wireguard client, so in general, I think my routing is ok on the server. It's probably some issue on the macOS routing side.



Thanks for any help you all can give!



Here is my client conf file:

[Interface]

PrivateKey = <client2privatekey>

Address = 10.10.9.4/32

DNS = 192.168.0.4



[Peer]

PublicKey = <serverpublickey>

Endpoint = my domain.com:51820

AllowedIPs = 0.0.0.0/0, ::/0



Here is my server wg0.conf ( I have 2 peers set up--the first is the working iOS client):

[Interface]

Address = 10.10.9.1/24

ListenPort = 501



PrivateKey = <servreprivatekey>

PostUp = iptables -A FORWARD -i %i -j ACCEPT; iptables -A FORWARD -o %i -j ACCEPT; iptables -t nat -A POSTROUTING -o wlan0 -j MASQUERADE

PostDown = iptables -D FORWARD -i %i -j ACCEPT; iptables -D FORWARD -o %i -j ACCEPT; iptables -t nat -D POSTROUTING -o wlan0 -j MASQUERADE



[Peer]

#Client1

PublicKey <client1publickey>

AllowedIPs = 10.10.9.2/32



[Peer]

#Client2

PublicKey = <client2publickey>

AllowedIPs = 10.10.9.4/32

Offline

Board footer

Powered by FluxBB