TunSafe Forum

Welcome to the TunSafe Community Forum. This is open for discussions related to TunSafe and the WireGuard protocol.

You are not logged in.

#1 2019-06-30 18:40:58

Stekahe
Member
Registered: 2019-06-30
Posts: 1

use tunsafe in openwrt-router

Hi,
Tunsafe works on Windows. I am searching for a solution using wireguard with openwrt. In openwrt i have the wireguard-protokoll, but there ist no explanation how to set it up. I tried a lot of hours, but cannot find the right parameters for the interface and the firewall. Is there an example?
Best regards
Stefan

Offline

#2 2019-06-30 19:57:02

logcabin
Member
Registered: 2018-04-30
Posts: 27

Re: use tunsafe in openwrt-router

Try this for a start (you'll need to modify the instructions as they are for AzireVPN):

https://www.azirevpn.com/support/guides … /wireguard

Last edited by logcabin (2019-06-30 19:59:45)

Offline

#3 2019-09-15 11:13:15

rapido
Member
Registered: 2019-09-15
Posts: 1

Re: use tunsafe in openwrt-router

is there an example how to setup Wireguard for Openwrt? The explanation by AzireVPN is ambiguous as which key to fill in where.

Offline

#4 2019-09-16 13:14:09

logcabin
Member
Registered: 2018-04-30
Posts: 27

Re: use tunsafe in openwrt-router

The private key goes in the Private Key field, which is in the Common Configuration section.

The public key goes in the Public Key field, available under endpoint_pubkey.

Offline

#5 2019-11-27 18:02:53

thiagotra
Member
Registered: 2019-11-27
Posts: 1

Re: use tunsafe in openwrt-router

I am having an issue using Wireguard and OpenWRT with TunSafe.
Everytime I reboot the router, I lose internet connection. Wireguard just send packets but doesn't receive any.
To put it back to work, I need to generate a new key in TunSafe website and change my private key and IP address. Doing this, works. Why?

Offline

Board footer

Powered by FluxBB