TunSafe Forum

Welcome to the TunSafe Community Forum. This is open for discussions related to TunSafe and the WireGuard protocol.

You are not logged in.

#1 2018-07-22 17:25:57

luelistan
Member
Registered: 2018-07-22
Posts: 2

[solved] OpenTapAdapter failing

Hello,
I'm just trying out Tunsafe and can't get it to work. In the log file, I get the message "OpenTapAdapter: CreateFile failed: 0x2... retrying" (repeats 10 times, then stops).
On my computer, OpenVPN is already installed, and there is a network device called "ovpn-tap". Could this somehow cause a problem? How can I debug this further?
Kind regards,
Max

Last edited by luelistan (2018-07-22 20:23:39)

Offline

#2 2018-07-22 17:27:23

ludde
Administrator
Registered: 2018-03-09
Posts: 127

Re: [solved] OpenTapAdapter failing

Did you install the TunSafe tap driver? Normally it should be able to use OpenVPN's but maybe it doesn't work for some reason.
Also I assume OpenVPN is not running at the same time?

Offline

#3 2018-07-22 20:23:21

luelistan
Member
Registered: 2018-07-22
Posts: 2

Re: [solved] OpenTapAdapter failing

I thought that the tap driver was automatically installed when I installed Tunsafe (I used the recommended Installer from the download page). However, running the driver setup from the program directory (TunSafe-TAP Installer.exe) manually has helped. Now it works, thanks smile

Offline

#4 2019-04-15 12:17:36

ngudobin
Member
Registered: 2019-04-15
Posts: 1

Re: [solved] OpenTapAdapter failing

Hi, I'm trying to use OpenVPN and TunSafe on Windows 10. I created two TAP drivers. If I turne OpenVPN service down,  TunSafe can initialise the TAP driver (created by OpenVPN). If OpenVPN is activated, TunFase cannot initialise the TAP driver. Obvousely TunSafe cannot run concurrenty to OpenVPN?

Thanks for replay.

Offline

Board footer

Powered by FluxBB